// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?sx)(?sx)
Container\("\w+"\)\.(?:TextCtrls|LabelCtrls)\("(?<ControlName>\w+)"\).Text"#).unwrap();
let string = "Container(\"Name1\").TextCtrls(\"Name2\").Text
Container(\"Name1\").LabelCtrls(\"Name2\").Text";
let substitution = "\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}