$re = '/(?sx)
Container\("\w+"\)\.(?:TextCtrls|LabelCtrls)\("(?<ControlName>\w+)"\).Text/sx';
$str = 'Container("Name1").TextCtrls("Name2").Text
Container("Name1").LabelCtrls("Name2").Text';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;