re = /(?sx)
Container\("\w+"\)\.(?:TextCtrls|LabelCtrls)\("(?<ControlName>\w+)"\).Text/x
str = 'Container("Name1").TextCtrls("Name2").Text
Container("Name1").LabelCtrls("Name2").Text'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result