const regex = /(?sx)
Container\("\w+"\)\.(?:TextCtrls|LabelCtrls)\("(?<ControlName>\w+)"\).Text/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?sx)
Container\\("\\w+"\\)\\.(?:TextCtrls|LabelCtrls)\\("(?<ControlName>\\w+)"\\).Text', 'gs')
const str = `Container("Name1").TextCtrls("Name2").Text
Container("Name1").LabelCtrls("Name2").Text`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);