using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(product-size|product-column|product-info|product-(1|2|3)+)\b";
string input = @"<div id='product-123'
class='product-1200px product-summary'>
</div>
<div id='product-124'
class='product-1200px product-info'>
</div>
<div id='product-321'
class='product-1200px product-column'>
</div>
<div id='product-324'
class='product-1200px product-size'>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}