const regex = /(product-size|product-column|product-info|product-(1|2|3)+)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(product-size|product-column|product-info|product-(1|2|3)+)\\b', 'gm')
const str = `<div id='product-123'
class='product-1200px product-summary'>
</div>
<div id='product-124'
class='product-1200px product-info'>
</div>
<div id='product-321'
class='product-1200px product-column'>
</div>
<div id='product-324'
class='product-1200px product-size'>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}