# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(product-size|product-column|product-info|product-(1|2|3)+)\b"
test_str = ("<div id='product-123'\n"
" class='product-1200px product-summary'>\n"
"</div>\n"
"<div id='product-124'\n"
" class='product-1200px product-info'>\n"
"</div>\n"
"<div id='product-321'\n"
" class='product-1200px product-column'>\n"
"</div>\n"
"<div id='product-324'\n"
" class='product-1200px product-size'>\n"
"</div>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.