package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(product-size|product-column|product-info|product-(1|2|3)+)\b`)
var str = `<div id='product-123'
class='product-1200px product-summary'>
</div>
<div id='product-124'
class='product-1200px product-info'>
</div>
<div id='product-321'
class='product-1200px product-column'>
</div>
<div id='product-324'
class='product-1200px product-size'>
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}