use strict;
my $str = '<div id=\'product-123\'
class=\'product-1200px product-summary\'>
</div>
<div id=\'product-124\'
class=\'product-1200px product-info\'>
</div>
<div id=\'product-321\'
class=\'product-1200px product-column\'>
</div>
<div id=\'product-324\'
class=\'product-1200px product-size\'>
</div>';
my $regex = qr/(product-size|product-column|product-info|product-(1|2|3)+)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}