$re = '/(product-size|product-column|product-info|product-(1|2|3)+)\b/m';
$str = '<div id=\'product-123\'
class=\'product-1200px product-summary\'>
</div>
<div id=\'product-124\'
class=\'product-1200px product-info\'>
</div>
<div id=\'product-321\'
class=\'product-1200px product-column\'>
</div>
<div id=\'product-324\'
class=\'product-1200px product-size\'>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);