// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(product-size|product-column|product-info|product-(1|2|3)+)\b").unwrap();
let string = "<div id='product-123'
class='product-1200px product-summary'>
</div>
<div id='product-124'
class='product-1200px product-info'>
</div>
<div id='product-321'
class='product-1200px product-column'>
</div>
<div id='product-324'
class='product-1200px product-size'>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}