re = /(product-size|product-column|product-info|product-(1|2|3)+)\b/m
str = '<div id=\'product-123\'
class=\'product-1200px product-summary\'>
</div>
<div id=\'product-124\'
class=\'product-1200px product-info\'>
</div>
<div id=\'product-321\'
class=\'product-1200px product-column\'>
</div>
<div id=\'product-324\'
class=\'product-1200px product-size\'>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end