import Foundation
let pattern = #"(product-size|product-column|product-info|product-(1|2|3)+)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div id='product-123'
class='product-1200px product-summary'>
</div>
<div id='product-124'
class='product-1200px product-info'>
</div>
<div id='product-321'
class='product-1200px product-column'>
</div>
<div id='product-324'
class='product-1200px product-size'>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)