import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(product-size|product-column|product-info|product-(1|2|3)+)\\b";
final String string = "<div id='product-123'\n"
+ " class='product-1200px product-summary'>\n"
+ "</div>\n"
+ "<div id='product-124'\n"
+ " class='product-1200px product-info'>\n"
+ "</div>\n"
+ "<div id='product-321'\n"
+ " class='product-1200px product-column'>\n"
+ "</div>\n"
+ "<div id='product-324'\n"
+ " class='product-1200px product-size'>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}