# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/\*(\*(?!\\/)|[^*])*\*\\/|\\/\\/.*//gm;t' <<< "/*
Block comment at the top
*/
{
\"foo\": {
\"abc\": [ // inline comment
123,
456 // another inline comment
]
},
/*
Block comment in the middle
*/
\"bar\": 999 // one more inline comment
}
"