using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*(\*(?!\/)|[^*])*\*\/|\/\/.*";
string substitution = @"";
string input = @"/*
Block comment at the top
*/
{
""foo"": {
""abc"": [ // inline comment
123,
456 // another inline comment
]
},
/*
Block comment in the middle
*/
""bar"": 999 // one more inline comment
}
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}