re = /\/\*(\*(?!\/)|[^*])*\*\/|\/\/.*/m
str = '/*
Block comment at the top
*/
{
"foo": {
"abc": [ // inline comment
123,
456 // another inline comment
]
},
/*
Block comment in the middle
*/
"bar": 999 // one more inline comment
}
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result