# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/\*(\*(?!\/)|[^*])*\*\/|\/\/.*"
test_str = ("/*\n"
" Block comment at the top\n"
" */\n"
"{\n"
" \"foo\": {\n"
" \"abc\": [ // inline comment\n"
" 123,\n"
" 456 // another inline comment\n"
" ]\n"
" },\n"
" /* \n"
" Block comment in the middle \n"
" */\n"
" \"bar\": 999 // one more inline comment\n"
"}\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.