$re = '/\/\*(\*(?!\/)|[^*])*\*\/|\/\/.*/m';
$str = '/*
Block comment at the top
*/
{
"foo": {
"abc": [ // inline comment
123,
456 // another inline comment
]
},
/*
Block comment in the middle
*/
"bar": 999 // one more inline comment
}
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;