const regex = /\/\*(\*(?!\/)|[^*])*\*\/|\/\/.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*(\\*(?!\\\/)|[^*])*\\*\\\/|\\\/\\\/.*', 'gm')
const str = `/*
Block comment at the top
*/
{
"foo": {
"abc": [ // inline comment
123,
456 // another inline comment
]
},
/*
Block comment in the middle
*/
"bar": 999 // one more inline comment
}
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);