#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\/\*(\*(?!\/)|[^*])*\*\/|\/\/.*"
Local $sString = "/*" & @CRLF & _
" Block comment at the top" & @CRLF & _
" */" & @CRLF & _
"{" & @CRLF & _
" "foo": {" & @CRLF & _
" "abc": [ // inline comment" & @CRLF & _
" 123," & @CRLF & _
" 456 // another inline comment" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" /* " & @CRLF & _
" Block comment in the middle " & @CRLF & _
" */" & @CRLF & _
" "bar": 999 // one more inline comment" & @CRLF & _
"}" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)