import Foundation
let pattern = #"\/\*(\*(?!\/)|[^*])*\*\/|\/\/.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/*
Block comment at the top
*/
{
"foo": {
"abc": [ // inline comment
123,
456 // another inline comment
]
},
/*
Block comment in the middle
*/
"bar": 999 // one more inline comment
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)