use strict;
my $str = '/*
Block comment at the top
*/
{
"foo": {
"abc": [ // inline comment
123,
456 // another inline comment
]
},
/*
Block comment in the middle
*/
"bar": 999 // one more inline comment
}
';
my $regex = qr/\/\*(\*(?!\/)|[^*])*\*\/|\/\/.*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";