import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*(\\*(?!\\/)|[^*])*\\*\\/|\\/\\/.*";
final String string = "/*\n"
+ " Block comment at the top\n"
+ " */\n"
+ "{\n"
+ " \"foo\": {\n"
+ " \"abc\": [ // inline comment\n"
+ " 123,\n"
+ " 456 // another inline comment\n"
+ " ]\n"
+ " },\n"
+ " /* \n"
+ " Block comment in the middle \n"
+ " */\n"
+ " \"bar\": 999 // one more inline comment\n"
+ "}\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}