import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(window\\.__AH_DATA__= \\{.*\\}\\\\n\\\\n window\\.__APOLLO_STATE__= \\{\\})";
final String string = "je vader window.__AH_DATA__= {gert}\\n\\n window.__APOLLO_STATE__= {} je moeder";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}