re = /(window\.__AH_DATA__= {.*}\\n\\n window\.__APOLLO_STATE__= {})/m
str = 'je vader window.__AH_DATA__= {gert}\\n\\n window.__APOLLO_STATE__= {} je moeder'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result