const regex = /(window\.__AH_DATA__= {.*}\\n\\n window\.__APOLLO_STATE__= {})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(window\\.__AH_DATA__= {.*}\\\\n\\\\n window\\.__APOLLO_STATE__= {})', 'gm')
const str = `je vader window.__AH_DATA__= {gert}\\n\\n window.__APOLLO_STATE__= {} je moeder`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);