# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.+?_([0-9]+)?_.+/$1/gm;t' <<< "foobar_foobar_190412_foobar_foobar.jpg
foobar_20190311_2372_foobar.jpg"