package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+?_([0-9]+)?_.+`)
var str = `foobar_foobar_190412_foobar_foobar.jpg
foobar_20190311_2372_foobar.jpg`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}