re = /.+?_([0-9]+)?_.+/m
str = 'foobar_foobar_190412_foobar_foobar.jpg
foobar_20190311_2372_foobar.jpg'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result