$re = '/.+?_([0-9]+)?_.+/m';
$str = 'foobar_foobar_190412_foobar_foobar.jpg
foobar_20190311_2372_foobar.jpg';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;