using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+?_([0-9]+)?_.+";
string substitution = @"$1";
string input = @"foobar_foobar_190412_foobar_foobar.jpg
foobar_20190311_2372_foobar.jpg";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}