use strict;
my $str = 'foobar_foobar_190412_foobar_foobar.jpg
foobar_20190311_2372_foobar.jpg';
my $regex = qr/.+?_([0-9]+)?_.+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";