import Foundation
let pattern = #".+?_([0-9]+)?_.+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foobar_foobar_190412_foobar_foobar.jpg
foobar_20190311_2372_foobar.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)