const regex = /.+?_([0-9]+)?_.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+?_([0-9]+)?_.+', 'gm')
const str = `foobar_foobar_190412_foobar_foobar.jpg
foobar_20190311_2372_foobar.jpg`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);