using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s\|\s)|(?:\s\|)|(?:\|\s)";
string substitution = @"|";
string input = @"12| 150 | test one| 33235
13| 151| test two |33236";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}