import re
regex = re.compile(r"(?:\s\|\s)|(?:\s\|)|(?:\|\s)")
test_str = ("12| 150 | test one| 33235\n"
"13| 151| test two |33236")
subst = "|"
result = regex.sub(subst, test_str)
if result:
print(result)