import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s\\|\\s)|(?:\\s\\|)|(?:\\|\\s)";
final String string = "12| 150 | test one| 33235\n"
+ "13| 151| test two |33236";
final String subst = "|";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}