$re = '/(?:\s\|\s)|(?:\s\|)|(?:\|\s)/';
$str = '12| 150 | test one| 33235
13| 151| test two |33236';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;