import Foundation
let pattern = #"(?:\s\|\s)|(?:\s\|)|(?:\|\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
12| 150 | test one| 33235
13| 151| test two |33236
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)