# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^\n\r]*?PVD-666432[^\n\r]*+\n?//gmi;t' <<< "abc PVD-666432def
abc PVD-666432 def
abcPVD-666432
abcd efg
PVD-666432abc
ab cd ef
PVD-666432 abc"