import Foundation
let pattern = #"^[^\n\r]*?PVD-666432[^\n\r]*+\n?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
abc PVD-666432def
abc PVD-666432 def
abcPVD-666432
abcd efg
PVD-666432abc
ab cd ef
PVD-666432 abc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)