#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^[^\n\r]*?PVD-666432[^\n\r]*+\n?"
Local $sString = "abc PVD-666432def" & @CRLF & _
"abc PVD-666432 def" & @CRLF & _
"abcPVD-666432" & @CRLF & _
"" & @CRLF & _
"abcd efg" & @CRLF & _
"PVD-666432abc" & @CRLF & _
"" & @CRLF & _
"ab cd ef" & @CRLF & _
"PVD-666432 abc"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)