// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[^\n\r]*?PVD-666432[^\n\r]*+\n?").unwrap();
let string = "abc PVD-666432def
abc PVD-666432 def
abcPVD-666432
abcd efg
PVD-666432abc
ab cd ef
PVD-666432 abc";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}