# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\n\r]*?PVD-666432[^\n\r]*+\n?"
test_str = ("abc PVD-666432def\n"
"abc PVD-666432 def\n"
"abcPVD-666432\n\n"
"abcd efg\n"
"PVD-666432abc\n\n"
"ab cd ef\n"
"PVD-666432 abc")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.