package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[^\n\r]*?PVD-666432[^\n\r]*+\n?`)
var str = `abc PVD-666432def
abc PVD-666432 def
abcPVD-666432
abcd efg
PVD-666432abc
ab cd ef
PVD-666432 abc`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}