const regex = /^[^\n\r]*?PVD-666432[^\n\r]*+\n?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\n\\r]*?PVD-666432[^\\n\\r]*+\\n?', 'gmi')
const str = `abc PVD-666432def
abc PVD-666432 def
abcPVD-666432
abcd efg
PVD-666432abc
ab cd ef
PVD-666432 abc`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);