re = /^[^\n\r]*?PVD-666432[^\n\r]*+\n?/mi
str = 'abc PVD-666432def
abc PVD-666432 def
abcPVD-666432
abcd efg
PVD-666432abc
ab cd ef
PVD-666432 abc'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result