# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b\d+(?:\,\d+)*(?:\.\d+)?[fd]?\b/./gm;t' <<< "52,52d
65.00f
123,50
1,234,567,89
1,234,567.89"