use strict;
my $str = '52,52d
65.00f
123,50
1,234,567,89
1,234,567.89';
my $regex = qr/\b\d+(?:\,\d+)*(?:\.\d+)?[fd]?\b/mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";